UCloud-201705-005:Samba远程代码执行漏洞安全预警 | U刻
  • UCloud-201705-005:Samba远程代码执行漏洞安全预警

    栏目:安全资讯

    尊敬的UCloud用户:

    5月24日Samba发布了4.6.4版本,中间修复了一个严重的远程代码执行漏洞(CVE-2017-7494),漏洞影响了 Samba 3.5.0 至4.6.4/4.5.10/4.4.14中间的所有版本。请及时检查您使用的Samba 是否受影响,并及时升级修复。

    影响范围
    Samba Version < 4.6.4
    Samba Version < 4.5.10

    Samba Version < 4.4.14

    修复方案
    1、缓解策略:用户可以通过在smb.conf的[global]节点下增加 nt pipe support = no 选项,然后重新启动samba服务, 以此达到缓解该漏洞的效果。
    2、使用源码安装的Samba用户,请尽快下载最新的Samba版本手动更新;

    3、使用二进制分发包(RPM等方式)的用户立即进行yum,apt-get update等安全更新操作。

    漏洞详情

    CVE-2017-7494:Samba服务器软件存在远程执行代码漏洞。攻击者可以利用客户端将指定库文件上传到具有可写权限的共享目录,会导致服务器加载并执行指定的库文件,这样通过一个可写入的Samba用户权限就可以提权到samba所在服务器的root权限。

    参考链接